Results 1 to 4 of 4

Thread: Ahlborn SL61 query

  1. #1
    Civilian
    Join Date
    Mar 2014
    Posts
    2

    Ahlborn SL61 query

    About a year ago I acquired a portable Ahlborn SL61 which was gifted to our church benefice because it was surplus to requirements at its previous home. I use it for occasional services in the mission hall, as a chancel organ to accompany a very small choir in one of the two parish churches within the benefice where the main organ is on a balcony at the back, for outdoor services such as Remembrance Sunday at the war memorial, to accompany carol singing at Christmas in local care homes etc. So it has been worth its weight in gold since we received it. However, there is one annoying problem, which is that there is usually a long interval between switxhing the organ on and it actually bursting into life. Sometimes it works immediately, sometimes it can be several minutes, occasionally up to almost an hour.
    Does anyone have any idea what could be causing this and whether it is relatively simple to correct? I did email the Ahlborn help line but got no reply from them.
    This is my first post on this forum but I hope someone may have an answer which can be understood by an old codger.

  2. #2
    Vice Admiral Virtuoso wljmrbill's Avatar
    Join Date
    Feb 2009
    Location
    Taylors, South Carolina, USA
    Posts
    3,179
    Welcome to the forums.. SOunds like a handy instrument to have around. My guess would be - if has tubes- may need to have them checked..if not perhaps a circut board problem. A organ electronic tech may be able to help you out.Good Luck
    ....To play only what is written is the domain of science. To realize what is not written is the domain of art."
    - Jean Langlais

    I wish you the Best for each day, now and always.

    Bill

  3. #3
    Administrator Krummhorn's Avatar
    Join Date
    Aug 2006
    Location
    Tucson, Arizona
    Posts
    8,003
    The SL-61 is a transistorized keyboard ...

    Ahlborn SL61 query-sl61_g-jpg

    Chances are that there is something awry within its electronic circuitry ... could be a capacitor going out or even a simple cold solder joint.

    The best thing to do is take this to a reputable electronic technician as troubleshooting this kind of problem is not a 'user fix' and may require parts to be replaced.

    The random 'warm up' times are a complete mystery ... usually electronics are either "on" or "off" and not usually somewhere between. If it is a cold solder joint, it could be affected by the weather, particularly if this keyboard is stored in a cold and/or damp closet between use.

    Still, it's best to have it checked out by an electronics technician. Maybe your parish has such an individual ... or you can solicit funds for the repair. The repair would be lots cheaper than replacement.

    Kh ♫

  4. #4
    Civilian
    Join Date
    Mar 2014
    Posts
    2
    Thank you both for those replies. I suspect the cold could be a factor but will see about having it checked out.I did suss out that if I left the on/off switch on but turned the power off at the mains it seemed to get around the problem but it has recurred recently even if I do this. Thanks again.

Similar Threads

  1. Service Manual for Ahlborn Hymnus
    By Kathyza in forum Electronic/Digital Organs
    Replies: 6
    Last Post: Nov-19-2015, 00:57
  2. Windoze query
    By Dorsetmike in forum Open Debate Forum
    Replies: 5
    Last Post: Nov-04-2012, 06:38
  3. Registration query
    By Dorsetmike in forum Pipe Organ Forum
    Replies: 8
    Last Post: Apr-16-2010, 01:39
  4. Cavaille Col and Silbermann Ahlborn Archive chipset wanted
    By Organ Matters in forum Electronic/Digital Organs
    Replies: 0
    Last Post: Apr-12-2010, 14:18
  5. jOrgan query
    By Mark B in forum Electronic/Digital Organs
    Replies: 32
    Last Post: Nov-28-2009, 22:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •